
Version：V1.1 MShot Image Analysis System

M-SHOT
User Manual
MShot Image Analysis SystemV1.1

Software Right：Guangzhou Micro-shot Technology Co., Ltd 2019



Version：V1.1 MShot Image Analysis System

Content
1.Open the M-shot imaging door.........................................................................................................-1-
1.1 Introduction.......................................................................................................................................................-1-

1.1.1 Writing purpose.....................................................................................................................................................................-1-

1.1.2 Background...........................................................................................................................................................................-1-

1.1.3 Reference terms....................................................................................................................................................................-1-

Run surrounding.....................................................................................................................................................................-1-

Available OS..........................................................................................................................................................................-2-

Available language.................................................................................................................................................................-2-

2.Imaging system installtion................................................................................................................-2-
3. Enter microscope imaging world...................................................................................................- 4 -
3.1Start the software...............................................................................................................................................-4-
3.2Open camera (Connect Directshow device)......................................................................................................-5-
3.3Select photo directory........................................................................................................................................-6-

3.3.1 Select catalogue....................................................................................................................................................................-6-

3.3.2 Expand directory..................................................................................................................................................................-6-

3.3.3 Pack up contents panel.........................................................................................................................................................-6-

3.3.4 New folder............................................................................................................................................................................-6-

3.3.5 Open/delete image................................................................................................................................................................-7-

3.4Photograph.......................................................................................................................................................-7-
3.4.1Single frame photgraphy.......................................................................................................................................................-7-

3.4.2Timing photographing...........................................................................................................................................................-8-

3.4.3Real time photographing.......................................................................................................................................................-8-

3.5Video function................................................................................................................................................-8-
3.6Image naming..................................................................................................................................................-9-
3.7Save.................................................................................................................................................................-9-
3.8Setting interface description............................................................................................................................-9-

4. Function module..........................................................................................................................- 10 -
4.1Exposure control............................................................................................................................................-10-
4.2Image settings................................................................................................................................................-12-
4.3Image processing...........................................................................................................................................-13-
4.4Color control..................................................................................................................................................-14-
4.5Fluorescence processing................................................................................................................................-15-
4.6Measurement..................................................................................................................................................-16-
4.7Histogram.......................................................................................................................................................-19-
4.8Static image processing.................................................................................................................................-20-

5. Advanced function setting........................................................................................................... - 21 -
5.1Color matrix...................................................................................................................................................-21-
5.2Flat field correction........................................................................................................................................-22-
5.3Color point correction....................................................................................................................................-22-

6. User login and management........................................................................................................ - 22 -
6.1Login system..................................................................................................................................................-22-
6.2Control and manage users..............................................................................................................................-23-

7 System log.................................................................................................................................... - 23 -



Version：V1.1 MShot Image Analysis System

8.Connecting other device(Directshow interface).............................................................................-24-
9.Help................................................................................................................................................-25-
9.1About...............................................................................................................................................................-25-
9.2Full screen display...........................................................................................................................................-25-



Version：V1.1 MShot Image Analysis System

- 1 -

1 Open the M-shot imaging door

1.1 Introduction

1.1.1 Writing purpose

It is applicable to all users of the software and provides detailed operation instructions.

1.1.2 Background

With the development of face recognition intelligent technology, the development of image acquisition and
processing software has become the focus of all parties. In the field of micro imaging, image processing software
involving intelligent and information technology is more and more urgently needed, especially the great progress of
micro scientific research, such as depth of field, splicing, fluorescence processing, which is difficult to observe
accurately under the eyepiece vision, M-shot image analysis system adapts to the current development trend,
optimizes the camera effect and adds functions based on the original software.

1.1.3 Reference terms

The MShot Image Analysis System (msany) is the latest camera control and image

optimization software of Mshot Optical Technology Co., Ltd. It mainly uses the

computer to control the camera to collect the image and video source, and presents the

effect of synthesizing, measuring and transforming the collected image through the

software, which makes it easy to collect and optimize the image. It is mainly used in

medical micro imaging, industrial detection, fluorescence imaging and other fields. It is

fully compatible with the camera model developed by MSHOT company and the

DirectShow device of windows system. It can be used across multiple platforms and has powerful functions,

providing convenience for the development of fluorescence imaging field.

Run Surrounding

Software：

Microsoft .NET Framework platform

Hardware：

CPU：Intel core 2 duo E2140 above

Memory：4GB above
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Hard disk：160GB above

 Available OS

Microsoft Windows:

32 bitWindows7，Windows8，Windows10；

64 bit Windows7，Windows8，Windows10；

 Available language

Standard language package：1.Simplified Chinese 2.English

Acceptable customize other languages 1.Complex Chinese 2. German 3. Japanese 4.Russia 5.France

6. Italian

2 Imaging system installation

Find software program and driver file in coming CD with camera,

copy to PC.

Open driver file to find ‘installer.exe’ , double left click the installer to install driver.

After successful install camera matched driver. Double click software program to install the software

according to Popup widnows tips.
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Click ‘Next’ to process installation.

Choose file you want to save the installed program or just save to default file.

Click ‘Install’ and wait it to install. If PC has security software to ask for authority, please allow to install the
software.
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Click ‘Finish’ to finish installing software and get the icon in PC desktop.

3 Enter microscope imaging world

3.1 Start the software

After successful installing the software, left double click the software icon ‘ ’ in PC desktop, software will

be run and show UI.

Menu bar

Expand the file directory panel
Expand image panel

Pause\Play
Snap
Record video
Zoom

Menu bar

Toolbox
All functions menu
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● Status bar introduction

3.2 Open camera（Connect Directshow device）

Click ‘File > Connect camera’ in turn, and M-shot will automatically detect the camera driver software installed on
the computer, and initialize the camera to display the current image in the preview window. After the detection, all
the detected camera models will be added to the camera list of toolbox ‘ ’ in the form of submenu. Click to
switch the camera, initialize the camera, and display a dynamic picture of the preview window.

Note: M-shot support connecting the same item camera synchronously, order by camera series number.

If do not use camera manufactured by M-shot, click ‘File> Connect Directshow device’ in turn, and M-shot will
automatically detect available camera for the Directshow, and initialize the preview window.

Name Icon Function

Dust bin Located under the image library, use to delete the selected image and information

RGB Channel Under the image library, modify the static image to single channel mode

Run Status Show current camera working status, Play : image in time view , Pause : static image view

Preview resolution Resolution under current preview status

Definition Definition under current preview status

Capture frame rate Frame rate when capture image

Process frame rate Frame rate under preview

Position Mouse pointed position

RGB RGB value of mouse pointed position

Zoom radio Show current image and default size zoom radio
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3.3 Select photo directory

Click ‘Tools > common settings’ in turn, click ‘ ’in the current directory to select the file directory or build a

new folder to select, or expand the file directory panel ‘ ’and double-click the selected file name.

3.3.1 Select catalogue

Double click the file directory name to select the folder, and the folder will
turn blue

3.3.2 Expand directory

If you select a file under a folder，click to expand directory

3.3.3 Pack up contents panel

Click to pack up the contents panel

3.3.4 New folder

Click and expand the ‘ ’ file menu under file
directory panel to add new folder. Click and open to input folder name,
click【OK】to add new folder. Close or click【Cancel】to cancel setting.
Also can add new folder in common setting.

Fold catalogue

Unfold catalogue tree
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3.3.5 Open/delete image

Double click the selected folder and click ‘ ’ to expand the image list. You can see the

image thumbnail under the selected folder in the image panel list. Double click the image

to open it. Double click the image name to rename it. Select the image and click ‘ ’

in the image panel to delete the image.

3.4 Photograph

3.4.1Single frame photography

Click the ‘ ’ icon above the preview window of the system interface to take a single frame photo.The picture

format and naming rules for taking photos can be selected through "Tools > common settings".

Note: the image saving formats supported by m-shot include TIF, BMP and jpg. TIF format pictures are
uncompressed pictures, which can be taken and saved up to 16 bits.

To switch image types, click toolbox panel ‘ ’ - > image settings ‘ ’- > image types

Note: bmp format picture is not compressed picture, only 8-bit picture shooting is supported.
The image in jpg format is a compressed image with a compression ratio of 75%.
Under the reset parameter, the default is jpg format.

Delete image
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3.4.2 Timing photographing:

Click ‘Tools’> ‘Common settings’ in the menu bar to set the timing time and interval time.
The time interval for taking pictures is set. The step value of seconds is 0.1 seconds, and the step value of minutes
is 1 minute. You can use the ‘’ on the
keyboard to make accurate adjustment.

All timing photographing step value are 1.

After setting the photographing time and
the photographing interval, select save file, click ‘Tools’ - > ‘Time photographing’ in the menu bar, and the
software system will save the photographing in the specified directory.

3.4.3 Real time photographing

Click ‘Tools’ - > ‘Common settings’ to set the real time photographing. The step value is 1s.

The number of real-time photos is (real-time time * processing frame rate), and the processing frame rate is
displayed in the status bar. After setting the real-time duration, select the save file, click ‘tools’ - > ‘real time
photographing’ in the menu bar, the software system saves the photographing in memory, and then writes it to the
specified directory of the disk.

3.5 Video function

Click ‘ ’ at the top of the preview window

of the system interface to record, and click ‘ ’ to stop recording. The video

format is WMV, which supports Microsoft's own player.
The video duration is the recording time, and the step value is 1s.
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The video format is WMV, which supports Microsoft's own player.

3.6 Image naming

M-shot provides three naming rules of auto customs naming (time, series
number, date+serial number).
Note: the default naming is valid for both photographing and video recording.

The time is 24 hours. For example, the first picture taken at 9:31:19 am on
September 7, 2018 is named 20180907093119072.
Serial number from ‘1,2,3...’ Sort.
Note: in case of reset, the time rule is the naming rule by default.

3.7 Save

Click ‘File’ - > ‘save’ in the menu bar to save the preview image. If the dynamic picture, save the file according to
the photographing resolution. In addition, save the file according to the resolution of the preview window (static
image save according to the original resolution)!

Click menu bar ‘File’ -> ‘Save as’, popup windows for save as, default image format is according to setting in
tools,it is available of three types image format, and rename.
Note: double click below renamed image to revise image name.

3.8 Setting interface description

Open the menu bar ‘Tools’ > ‘Common settings’ to open the Common settings, Advanced setting and Measurement
setting.

● Setting interface function introduction
Function Description

Common setting Set the time scheme of real-time photographing and timing photographing, set the format and naming rules of photo taking and

video recording, and select the software language

Advanced setting Set the color correction value, select the equipment accelerator, start the flat field correction to collect the correction
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information

Measurement

setting

Select the number of clicks, and process the numerical formula displayed after the drawing of the measuring tool and the

display of the text description

Reset Returns the set value to the default value.

OK Confirm option modification

Cancel Cancel the set operation and close the parameter setting window

4 Function module

4.1Exposure control

Single click right tool box ‘ ’ to expand toolbox panel -> Exposure control’ ’.

Function description Control panel identification Initialization settings recommendation

Auto exposure ： The software automatically

adjusts the exposure time according to the set

brightness (based on the camera, the exposure

time and gain are limited by the maximum

value).

Target brightness： It is the brightness of the

picture. After checking auto exposure, the

brightness of the target can be adjusted. Observe

the picture adjustment lever to the customized

brightness.

Global exposure：The overall brightness of the

whole picture reaches the target brightness.

Regional exposure：After clicking, the mouse

changes to a cross shape in the video area of the

video window. You can select any area in the

video window, which is mainly used to make the

selected target area reach the set target

brightness. It can be used to observe the details

of the brightness of the selected area, select the

dark area can improve the brightness of the

whole picture. Select bright area can make it

darker and details more obviously.

Time:Time to receive light for the chip

Gain:The brightness of the image signal

transmission data is adjusted by controlling the

1. Ordinary users are advised to select auto

exposure mode, set the target brightness, so that

the brightness can reach your visual comfort.

After the external light source changes, the

software will automatically restore the image

adjustment to the set target brightness value.

2. It is generally recommended to adjust by

Auto exposure & Auto gain or auto exposure

mode. The gain is adjusted by amplifying the

image signal to increase the interference of

electrical signal. (increase the gain value and

increase the brightness and noise

synchronously).

3. High configuration users can use manual

exposure mode to customize advanced settings

for exposure time and gain, as shown in the table

below. At this time, the target brightness

adjustment lever is not available.
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electrical signal. (increase noise).

Available Exposure mode of Auto exposure

 Auto exposure & Auto gain （Exposure

first）

 Auto gain &Auto exposure (Gain first)

 Auto exposure (The gain can be adjusted

manually, and the exposure time can be

adjusted automatically to make the

picture reach the target brightness)

 Auto gain（ The exposure time can be

adjusted manually, and the gain can be

adjusted automatically to make the

picture reach the target brightness）

Invert select auto exposure enter into manual

exposure mode

Exposure time setting

The second, millisecond and microsecond in the

icon are the exposure time settings. (the setting

of the value and the adjustment of the pull rod

can be adjusted by using the left and right

direction keys on the keyboard.)

Uncheck auto exposure to enter manual

exposure mode, when auto exposure & auto gain

is checked, the exposure time and gain cannot be

adjusted. But here you can view the current

exposure time.

Select auto exposure for exposure mode to

customize the gain value. Select auto gain to

customize the exposure value.

Advanced users are advised to use manual

exposure mode to customize advanced settings

for exposure time and gain. Advanced users can

set the exposure time accurately by inputting the

value manually or adjusting the exposure time

lever to control the brightness of the captured

image. When and only when the image and light

source brightness have reached the maximum

value and still do not meet the imaging

requirements, pull the gain lever until the image

brightness meets the requirements.

Anti stroboscopic：This function can eliminate

the image stroboscopic phenomenon caused by

different countries and regions or different light

source frequencies. Please select according to

the power characteristics you use.

Direct current：DC driven bulb

Overexposure：Mark the overexposure area red.

The alternating current in China is 50Hz.

If indoor incandescent lamp is used as camera

light source, 50Hz power frequency is generally

selected. (Note: at this time, the exposure time

can only be increased or decreased by an

integral multiple of 10. If 60Hz is used, the

exposure time can only be increased or

decreased by an integral multiple of 8.33.)
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Select to mark

overexposure area and processing brightness

adjustment.Overexposure performance:

4.2 Image settings

Click right side tool box ‘ ’ to expand toolbox panel > image settings ‘ ’
Function description Control panel identification Initialization settings recommendation

Preview resolution: Set real-time

Dynamic windows resolution.

Capture resolution: Set image capture

resolution

Preview:Select a smaller resolution similar to the

display window resolution for preview, and you

can get a faster frame rate.

Capture resolution: Select the maximum

resolution to achieve the best photo effect of the

camera.

Area image capture tool：

Click Quick ROI, mouse changes to a cross

shaped box, press and hold the left mouse button

to select some areas in the upper box of the

preview window, release the left mouse button to

preview the window to display the image after

box selection; cancel to stop ROI setting.

Click ROI setting to open ROI setting input box;

manually input the origin coordinate and length

and width of the area selected in the box. Click

OK to get the box selection area with the origin

coordinate as the origin of XY axis, width as the

width of matrix and height as the height of

matrix.

(Note: ROI setting value must not be greater

than preview resolution, e.g.: if preview

resolution is a * A1, X + width is less than or

equal to A, Y + height is less than or equal to

A1).
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Click ‘Cancel’ to quit ROI setting

Click to quit

Flip settings

Flip horizontally: if the image of the dynamic

preview window is horizontally opposite to what

you expect, select the box.

Flip vertically: if the vertical direction of the

dynamic preview window is opposite to the

expected direction, select the box.

1. After setting, the frame rate of dynamic

display will be reduced.

2. If the image has angle deviation on the

horizontal plane, you can try to rotate the

camera installation position (adjust the imaging

direction according to the chip) to debug.

Frame rate: it is the display frame rate of

dynamic preview, which is normal by default.

Image type: the bits saved in each pixel channel

during image saving. There are two formats.

BAYER_RG8 is a single byte image of 8-bit

data type.

BAYER_RG12 is a 12 bit data type image. (only

TIF format image supports image saving of 12

bit data type)

1. The color details of the image saved as

12 bit data type are more abundant.

However, it will reduce the frame rate,

which is suitable for image preservation

requiring rich color details. It can be

viewed through histogram.

12 bit data

histogram

8 bit data

histogram

It can be compared that the image details

are more abundant and the transition is

smooth.

4.3 Image processing

Click right side tool box ‘ ’ to expand tool box panel>image processing ‘ ’

Function description Control panel identification Initialization settings recommendation



Version：V1.1 MShot Image Analysis System

- 14 -

Image setting
Select the box in front of the function to adjust the

value of the function.

Gamma: change the brightness of the whole image,

pull the adjusting rod to the left to reduce the gamma

value, and pull the adjusting rod to the right to

increase the gamma value.

Contrast: improve the brightness contrast of the

whole image. Pull the adjusting rod to the left to

reduce the contrast, and pull the adjusting rod to the

right to improve the contrast.

Sharpness: improve the sharpness of the whole image

change, pull the adjusting rod to the left to reduce the

sharpness, and pull the adjusting rod to the right to

increase the sharpness.

(it can be synchronized and precisely adjusted by the

direction key of the keyboard)

When the halogen lamp / LED lamp with non

natural light is used for lighting.

Default：

Gama：It is suggested to adjust to1.00

Contrast: it is recommended to adjust to the

range of 100-120.

Sharpness: it is recommended to adjust to 0

2D noise reduction: it can optimize the image and

eliminate the noise. The value can be adjusted

synchronously and accurately by pulling the

direction key of the adjusting lever or keyboard.

Left and right key operation .

3D noise reduction: reduce the interference of weak

signal image, automatically filter out noise, make the

image more pure and delicate

Overlay noise reduction: keep low exposure and

bright picture

3D noise reduction: color separation during

preview, software slowing down, effective when

taking photos

3D noise reduction box drop-down selection

number, indicating

The superimposed noise reduction box can be

used for fluorescence imaging to make the

picture bright

4.4 Color control

Click right side tool box ‘ ’ to expand tool box panel > color setting ‘ ’

Function description Control panel identification Initialization settings recommendation
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Color control

R \ G \ B gain: pull the adjustment lever to

increase the image RGB gain value. The default

value is 1

Pull the adjusting rod to the left to lower R \ G\

B, and pull the adjusting rod to the right to

increase R \ G \ B.

Saturation: select the saturation box. After

selecting, you can adjust the image saturation by

pulling the adjustment lever. The higher the

saturation, the brighter it will be. The saturation

is small and the image is not obvious. Default

value 100.

Pull the adjusting rod to the left to reduce the

saturation, and pull the adjusting rod to the right

to increase the saturation.

(it can be synchronized and precisely adjusted by

the direction key of the keyboard).

When using halogen lamp with non natural light

\ LED lamp for lighting:

Saturation and R \ G \ B use default parameters

Picture white balance

Monochrome: convert the color picture of

preview window to black and white picture,

which can improve the processing efficiency of

picture. Select OK.

Inverse color: reverses the RGB value of each

pixel in the image, (R = 255-R). Select OK.

Automatic white balance: check to confirm and

apply the matrix to affect the overall color of the

screen, and the overall white balance will be

adjusted automatically.

Global white balance: picture white balance.

Area white balance: select the mouse to change

to a cross shaped box to select a picture. After

the box is selected, the area white balance is

adjusted for color temperature.

Getting started users recommend using

automatic white balance.

The global white balance needs to adjust

the picture to a blank background for white

balance, and the regional white balance

can be achieved by directly selecting the

white area in the image

If there are special requirements, color

temperature can be corrected by regional

white balance.

4.5 Fluorescence processing

Click right side tool box ‘ ’ to expand tool box panel > fluorescence processing ‘ ’

Function description Control panel identification Initialization settings recommendation
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Fluorescence processing
In the case of fluorescence is not obvious, display

effect under the superposition of fluorescence

brightness can achieve better visual effect.

Click ‘ ’，to take photo, the image list can display

the fluorescence processed image, which can be

compatible with 3 to 5 pictures, and the color

brightness of each channel of the synthesized image

remains unchanged. Click ‘ ’ after synthesis to
save.

Click OK to save

When the halogen lamp / LED lamp with non

natural light is used for lighting.

Default：

Gamma value: it is recommended to adjust to

1.00

Contrast: it is recommended to adjust to the

range of 100-120

Sharpness: it is recommended to adjust to 0

4.6 Measurement

Click right side tool box ‘ ’ to expand tool box panel > measurement ‘ ’

Note: to save the measurement picture, it is necessary to ensure that the preview resolution and photo resolution set in the
image settings are consistent in advance.

Function description Control panel identification Initialization settings recommendation

Measurement setting tools
1 text; 2 point count; 3 line segment; 4 free cut;

5. Rectangle; 6. Polygon; 7. Angle measurement;

8. Ellipse; 9. Circle at center + radius; 10. Circle

at two points; 11. Circle at three points; 12.

Parallel line; 13. Arrow; 14. Scale; 15. Energy

curve

Survey tools include commonly used 2D plane

drawing segments. When measuring, click to

draw the drawing or select the drawing to select

Measurement tools

After drawing the figure, you can select the

figure to adjust the font size, line width, length

and angle units of the figure in real time.

When drawing the measurement image, it is

necessary to ensure that the preview resolution is

the same as the photographing resolution,

otherwise the data cannot be saved.

Be careful! If you change the resolution when

drawing a measurement, all drawing shapes are

cleared by default.

21 3 4 5

8

11 12

9

13

6

14

107

15
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the measuring area.

For the measurement figures to be deleted, you

can select them and use [delete] on the keyboard

to delete them. Or click‘Clear’ to clear all the

measurement figures at one time.

You can click ‘Take photo’ or click ‘ File’ >

‘Save’ or ‘Save as’ to save after measurement.

The information displayed when the

measurement tool is drawn can be designed

through the menu bar ‘Tools’ > ‘Measurement

setting’.

Measurement setting

Calibration (Calibration setting)
1. Show the image of stage micrometer

(optional accessory) to software ( can use

real-time imaging or captured images), and

select ‘Calibration’ in measurement module.

2. Enter the objective magnification of the

current picture in the pop-up calibration dialog

box (for example, if the micrometer scale picture

is taken under 10x objective, the magnification

can be named 10x), the actual distance is the

length of the standard you want to select (each

small grid here represents 10 μ m, the

accuracy of different scales is different, the data

should be clear before calibration), and as many

choices as possible can be observed To reduce

the error. The pixel distance and resolution will

automatically generate parameters after

calibration. At this time, no modification is

made, and the scale length can be input as

required.

At this time, a red line segment will appear on

the software. Move the mouse cross to the

beginning and end of the line segment, and the

Calibration parameters setting

Calibration line segment

Calibration standard entrance

Magnification display

It is necessary to select the correct

magnification to match the actual situation.

Generally, the magnification and actual distance

of the camera are set according to the camera

model.

Click ‘Save’ after setting.

Modify: select the ruler to be modified, and set

the scale length value by clicking modify

【Calibration】.

Delete the calibration. Select the pop up ruler,

click 【Delete 】in the calibration window, and

then click OK.
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mouse will change to ‘ ’ to pull the

beginning and end of the line segment to the

actual length (if the actual length is 100 μ m,

the pull length will be 10 cells).

1. Click ‘Save’ > ‘Add’, switch to the next

objective, and calibrate the corresponding

objectives in the same way. After all objectives

are calibrated, the measuring tools can be used.

When need to display the current camera

magnification and inserted scale image, it can

click the calibration of the measurement module

for setting - > click ‘ ’ insert - > click the
calibration and input the value with * to

complete the calibrationThe value of the current

ruler is displayed.

After setting, the set camera magnification can

be displayed on the toolbox panel. If you select

it, you can directly click ‘ ’ to insert the
scale.

● Measurement tools function description
Functions Icon Description

Text Click to select, the icon will turn blue, and the mouse will turn to a cross. Select the location of the text to be added in

the image, and then the text mark content box will pop up. You can input the mark content as required, and select the

font size and color on the right.

Point count Click to select, the icon will turn blue, the mouse will turn to cross, manually click the sample to be calculated, the

system will automatically number it, and right click to confirm after counting manually. Point count options can be set

in ‘Tools’ > ‘Measurement setting’.

Line segment Click to select, the icon will turn blue, and the mouse will turn to a cross. It can be used to measure the distance of a

straight line. Pull the distance to be measured, and the measured length will be displayed.

Free curve Click to select, the icon will turn blue and the mouse will turn to a cross. You can draw a polyline to measure the

distance. Right click to confirm and display the measured length after pulling.

Rectangle Click to select, the icon will turn blue, and the mouse will turn to a cross. Pull the rectangle to be measured to display

the area, width and height. The parameter display options can be modified in ‘Tools’ > ‘Measurement setting’.

Polygon Click to select, the icon will turn blue, the mouse will turn to cross, pull the polygon to be measured, right-click to

confirm to display the area and perimeter, and the parameter display options can be modified in ‘Tools’ > ‘Measurement

setting’.

Angle

measurement

Click to select, the icon will turn blue, the mouse will turn to cross, and the angle to be measured will be displayed after

pulling.

Ellipse Click to select, the icon will turn blue, and the mouse will turn to a cross. After pulling the ellipse to be measured, the

long axis, short axis and area will be displayed. The parameter display options can be modified in ‘Tools’ >
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‘Measurement setting’.

Center of

circle +

Radius circle

Click to select, the icon will turn blue and the mouse will turn to a cross. Draw a circle through the center and radius to

display the radius, area and perimeter. The parameter display options can be modified in ‘Tools’ > ‘Measurement

setting’.

Two points

circle

Click to select, the icon will turn blue, and the mouse will turn to a cross. Draw a circle through three points to display

the radius, area and perimeter. The parameter display options can be modified in ‘Tools’ > ‘Measurement setting’.

Three points

circle

Click to select the three-point circle, the icon will turn blue, and the mouse will turn to a cross. Draw the circle through

three points to display the radius, area and perimeter. The parameter display options can be modified in ‘Tools’ >

‘Measurement setting’.

Parallel lines Click to select, the icon will turn blue, the mouse will turn to cross, draw two parallel lines and display the distance

between them. The parameter display options can be modified in ‘Tools’ > ‘Measurement setting’.

Arrow Click to select, the icon will turn blue, and the mouse will turn to a cross for indication and marking.

Scale Click the scale bar, the scale bar will appear on the screen, and the position of the scale bar can be dragged. It is

recommended to use after calibration.

Energy curve Click to select, the icon will turn blue, the mouse will turn to cross, pull the required area to display the energy curve.

High curve and brightness.

Note: the above measuring tools are recommended to be used after software calibration.

4.7 Histogram

Click right side tool box ‘ ’ to expand tool box panel > Histogram ‘ ’.

Function description Control panel identification Initialization settings recommendation

Histogram
Histogram can be used to view the distribution of the

number of pixels under each luminance level of

0-255. Histogram is the display of photo exposure,

showing the distribution of hue. According to the

histogram drawn by these values, the exposure effect

can be preliminarily determined. Visually see

whether the image has rich highlights, overexposure

or full dark details.

Abscissa: brightness (value range: 0-255)

Ordinate: the total number of pixels of brightness

corresponding to the abscissa.

Input color scale: middle color scale.

Output color scale: change the overall brightness of

the picture.

Pull the left and right bars of the histogram (input the

value accurately in the input color scale) to adjust the

brightness range of the input color scale. You can

select different color channels or three channels for

Generally, the middle color scale is set to 1 for

adjustment. It can adjust the brightness of the

whole picture synchronously.

Adjust the left pull rod: adjust the brightness of

the minimum value. The pixel point on the left of

the original pull rod is 0, showing black effect,

its value bigger, brightness darker and contrast

increased.

Adjust the brightness of the right pull rod, adjust

the brightness of the maximum value. The pixel

point on the right of the original pull rod is 255,

showing bright signal, its value smaller, image

signal brighter.

Pull the left pull rod to the right, the darker the

gray pixel is, and the right pull rod to the left,

white pixels are whiter.
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brightness adjustment.

Output color scale: pull the adjusting block to adjust

the brightness of the whole image, and input the

value manually to set accurately.

4.8 Static image processing

Click right side tool box ‘ ’ to expand tool box panel > static image processing ‘ ’.

Function description Control panel identification Initialization settings recommendation

Static image processing

Use this module only when still images are open

Brightness: adjust the pull rod to the right and the

image will be bright; adjust the pull rod to the left

and the image will be dark.

Contrast: adjust the pull rod to the right to increase

the contrast; adjust the pull rod to the left to reduce

the contrast.

Hue: adjust the pull rod, hue adjustment, color

change.

Saturation: adjust the pull rod to the left, and the

saturation increases.

Brightness: adjust the pull rod to the left, the image

will be bright, adjust the pull rod to the right, and the

image will be dark.

Gamma value: adjust the pull rod to the left, the

image becomes bright, adjust the pull rod to the right,

and the image becomes dark.

Default value:

Brightness, contrast and hue are 0;

Saturation and lightness are 0; gamma value is 1

Other settings

Clipping: double click to open the still image, click

the clipping of the still image processing, and select

the clipped image shape.

Graying: converts a color image to a black and

white image.

RGB splitting: double click to select the picture to

be split in the left picture library, and click RGB

splitting to complete the image RGB channel

separation.

Multi channel synthesis: synthesize images of

different colors: click multi-channel synthesis,

double-click the image to be synthesized in the left

Clipping: it can highlight the key areas in the

static image and enlarge the image.

Multichannel synthesis is mainly used for the

synthesis of fluorescence imaging.



Version：V1.1 MShot Image Analysis System

- 21 -

picture library, and then complete the image

synthesis.

Image cutting

5 Advanced function setting

5.1 Color matrix

Color balance can be corrected by color matrix. Setting path: menu bar
‘Tools’ - > ‘Advanced settings’ to input.
Based on the correction calculation of the original RGB value of the
original image, a new value is obtained, which is the corrected value.
5.1.1 turn on the camera and carry out area white balance for the dynamic
image to be corrected.
By clicking the drop-down list, you can select the matrix with positive
color or customize it.
After correcting the matrix, click ‘Apply’, and then click ‘OK’ of parameter setting.
After the region white balance of the image, the correction image can be obtained.
If you want to save the previous settings, you can click ‘Save as’ to save the set custom matrix. Click ‘Load’ to
apply the previously set matrix list for selection.
Matrix computation：
R1=a11*R+a12*G+a13*B
G1=a21*R+a22*G+a23*B
B1=a31*R+a32*G+a33*B
RGB is the R, G, B value of the original image, R1 G1 B1 is the corrected value after application.
Matrix a11 a12 a13

a21 a22 a23
a31 a32 a33
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Input the value and click apply to confirm that you can see the image after color balance。

5.2 Flat field correction

Flat field correction: the interference of uneven color distribution in the picture can be eliminated through flat field
correction, which needs to be corrected under the background of all white.

5.3 Color point correction

Flat field correction: the interference of uneven color distribution in the picture can be eliminated through flat field
correction, which needs to be corrected under the background of all white.

Color spot correction: due to the scattering of light in the picture, part of the color spots will be seen in the enlarged
image, which will affect the clarity and reducibility of the image. Color spot correction can cancel the color spots in
the picture.

6 User login and management

6.1 Login system

The system login requires account password. According to the specified permissions, it can be divided into ordinary
users and administrator users, with different account passwords assigned, and permissions assigned to maintain the
rights and interests of enterprises and users.

Ordinary users can use basic operations such as photographing (timed photographing, real-time photographing),
video recording, etc., and can set exposure control, image setting, image processing, color control. Static images
cannot be manipulated.

Compared with the ordinary users, when the administrator authorized users add advanced settings and measurement
display settings, the function module adds measurement, fluorescence processing, histogram, and static image
processing functions.
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6.2 Control and manage users

Click menu bar ‘System’ -> ‘System logs’ as management

7 System log

Click ‘System’ - > ‘System log’ in the menu bar to enter the system log. The system log can be used to record the
system login and photo taking operations, so that the user can view the main operations and obtain important
information.
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8 Connecting other device（Directshow interface）

The DirectShow parameter settings are determined by the camera used, taking the front camera provided with the
computer as an example. Click ‘File’ in the menu bar - > ‘Connect DirectShow’ device.

Camera PC property

DirectShow Interface parameter setting function description

Parameter setting Function Adjustment range
Brightness Adjust the brightness of the camera's

internal picture
Contrast Adjust the brightness level of the

image
Gamma Auxiliary brightness and contrast

adjustment
Tone Tone size adjustment
Saturation Saturation and brightness of screen

color
Sharpness Provide image segmentation edge
Anti flicker Set the anti stroboscopic of 50Hz \

60Hz
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Video Performance bias of video display
Default value Click recovery
Confirm Confirm revision
Apply（A） Click Apply after modification to

apply the modification

9 Help

9.1 About
View software version information

9.2 Full screen display
Menu bar ‘tool’ - > full screen display, play the current imaging interface in full screen, and exit with ESC key
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